Author Topic: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool  (Read 2217 times)

Offline pasKalou

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
[Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« on: November 07, 2012, 05:24:42 pm »
Hello,
i've updated my system from ubuntu 12.04 to ubuntu 12.10.
Now i can't use the R tool : pick color. The only color i have is black !

Do you know this trouble ?

PsKl

Offline achadwick

  • Administrator
  • Full Member
  • *****
  • Posts: 248
  • Karma: +9/-0
  • MyPaint developer and Mypaint-testing PPA owner
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #1 on: November 20, 2012, 02:07:42 pm »
Hello,
i've updated my system from ubuntu 12.04 to ubuntu 12.10.
Now i can't use the R tool : pick color. The only color i have is black !

Do you know this trouble ?

PsKl

Yeah, it happens on other OSes too. Under Linux it might be due to variations between window managers, or even hardware variations. Are you using Unity, and what graphics hardware does your computer use?

It's one of those eternal cyclic bugs. People complain they can't pick any colour off the screen, and that's useful so we change the implementation so they can to do this, which is susceptible to the problem you're seeing; people complain again so we change it back to only being able to pick from the canvas; back to step 1.

Anyway, we should probably make a workaround for people having this issue: meta-bug at https://gna.org/bugs/?20311

Edit: typo.
« Last Edit: November 21, 2012, 09:59:11 am by achadwick »

Offline pasKalou

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #2 on: November 20, 2012, 09:38:54 pm »
Hello

I've another computer now... But, i will try to help you.

Are you using Unity, and what graphics hardware does your computer use?

I was using Unity. But the trouble was the same with gnome-shell (3.6). The graphic hardware was ATI Mobility Radeon HD 5430.

Thank's for the explain
PsKl

Offline achadwick

  • Administrator
  • Full Member
  • *****
  • Posts: 248
  • Karma: +9/-0
  • MyPaint developer and Mypaint-testing PPA owner
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #3 on: December 02, 2012, 01:36:00 am »
This might be fixed by the experimental workaround in https://gitorious.org/mypaint/mypaint/commit/f38b4b8a52e7f679853992424b8d5cd985efec9c. Please can everyone bitten by this bug, or anything similar to it, check bug #20311, retest, and follow up there with your findings? Thanks.

Offline Cluly

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #4 on: December 02, 2012, 06:12:59 pm »
I've had the black pick bug and the sticking color picker too, I also had weird screen flickering when in full screen mode (f11) where the screen would white out after picking a color...This all seams to be resolved with the update that came via the PPA today (Ubuntu 12.10  Unity.)

Offline achadwick

  • Administrator
  • Full Member
  • *****
  • Posts: 248
  • Karma: +9/-0
  • MyPaint developer and Mypaint-testing PPA owner
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #5 on: December 02, 2012, 07:12:47 pm »
I've had the black pick bug and the sticking color picker too, I also had weird screen flickering when in full screen mode (f11) where the screen would white out after picking a color...This all seams to be resolved with the update that came via the PPA today (Ubuntu 12.10  Unity.)

Good stuff! What graphics hardware are you using, out of interest? Both the VM software and the host's graphics hardware seem to be important if you're running Unity in a VM.

Offline Cluly

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #6 on: December 02, 2012, 07:30:59 pm »
Radeon 5770 1024mb Single Slot Edition (Running dual monitors.)

Offline Cluly

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #7 on: December 04, 2012, 10:33:30 pm »
I seam to be getting the "sticking" color picker tool again while trying to draw a curve with the line tool. If I hit the Ctrl key too early (before starting the line/curve.) it sticks to the screen every time.

Offline achadwick

  • Administrator
  • Full Member
  • *****
  • Posts: 248
  • Karma: +9/-0
  • MyPaint developer and Mypaint-testing PPA owner
Re: [Ubuntu 12.10] Bug when i'm using "Pick Color" tool
« Reply #8 on: December 06, 2012, 02:59:33 am »
What does "sticking" mean?

Is this another instance of https://gna.org/bugs/?19710 at all? Please follow up there if it is.